h1

Lieto fine

11 maggio 2010

A casa dei miei c’è un PC, un vecchio AMD K6-2 600Mhz, con installati Windows XP e Ubuntu 10.04

Il primo impiega non meno di dieci minuti ad avviarsi seriamente, ed anche una volta avviato risulta troppo lento per essere davvero usabile, il secondo in meno di 5 minuti è up and running.

Ad ogni modo ieri mi sono trovato a compiere l’impresa di installare una multifunzione HP (la deskjet F2400) sul PC, e quindi su entrambi i sistemi operativi. Per esperienza personale immaginavo che in ogni caso l’installazione sarebbe stata più semplice su win: inserisci il cd, premi avanti/avanti/avanti(ad libitum) et voilà. Su Linux invece ero pronto a dover installare qualche driver, magari penare un pochino con lo scanner, insomma pensavo che avrei perso un po’ di tempo. Ne sarebbe comunque valsa la pena, per poter usare la stampante con software libero, ma mi aspettavo qualche sacrificio.

Parto da Windows: inserisco il CD, aspetto l’autorun e parto con la sequenza avanti/avanti/avanti. Giunto al punto in cui mi chiede in che drive installare il software, dato che il mio disco fisso (per imperscrutabile decisione di WinXP) è il drive J, mi propone il percorso J:\Programmi\HP. Accetto e clicco per l’ennesima volta su "avanti". La sorpresa mi coglie quando, a metà circa dell’installazione, un Fatal Error viene visualizzato a tutto schermo: di cosa si tratta? Semplicemente il percorso "c:\Programmi\HP" non è stato trovato. L’intera installazione del driver si basa sull’assunto che il drive principale sia C e, da qualche parte nel codice, non controlla dove si è deciso di installare il software ma va direttamente a puntare in C:\Programmi. Fatal error, installazione cancellata (dopo 5 minuti di rollback) e nessun modo, dico nessuno, per ovviare alla situazione. Cambiare la lettera del drive principale infatti è un’operazione di per se’ impossibile in Windows, se non usando tool un po’ esoterici (ricordo che Partition Magic aveva questa feature, a suo tempo).

Un po’ spaventato riavvio sotto Ubuntu, senza spegnere la multifunzione. Effettuo il login col mio utente e mi dirigo verso Sistema/Amministrazione/Stampanti per vedere di aggiungerla ai devices, ma con mia grande sorpresa noto che la stampante già c’è.

Apro OpenOffice.org, scrivo due righe e mando in stampa. E la stampa esce.
Meccanicamente carico il programma di scansione di Gnome, metto un foglio sullo scanner e clicco su "acquisisci". Lo scanner funziona.

Nessun bisogno di driver, di installazioni, di intervento alcuno da parte dell’utente. Un capolavoro.

E poi c’è ancora chi dice che Linux è troppo difficile per l’utente finale…

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: